Banniere du site
Nous sommes le Samedi 23 Septembre 2017
Il y a 1 personne(s) connecté(s) Le record est de 22 visiteurs simultanés le 07/10/2007 à 17:53

Configuration DHCP sur plusieurs réseaux d'un Routeur CISCO 1721



Prenons le contexte suivant: plusieurs VLANs sur des réseaux différents. Vous avez besoin d'un DHCP pour chaque réseau pour que chaque équipement réseau obtienne facilement une adresse IP. Nous avons un switch déjà configuré, où nous avons préparé un trunk pour récupérer la configuration des VLANs. (Voir ce dossier) Voici la configuration adéquate:

Router>en
Router>conf t
Router>int f0
Router>no shut
// Il est nécessaire de toujours faire un no shut pour s'assurer que l'interface est active
Router>int f0.10
Router>encapsulation dot1q 10
// 10 Correspond au numéro du VLAN, Attention, il doit aussi correspondre à votre réseau... ici 192.168.10.x
Router>ip address 192.168.10.1 255.255.255.0
// Adresse IP de l'interface, puis on défini le pool DHCP
Router>ip dhcp pool societe1
Router>network 192.168.10.0 255.255.255.0
Router>default-router 192.168.10.1
// On exclu les adresses dont on n'a pas besoin de la plage du DHCP
Router>ip dhcp excluded-address 192.168.10.1 192.168.10.100
Router>ip dhcp excluded-address 192.168.10.200 192.168.10.254
// Fin de la configuration pour le 1er réseau!
Router>int f0.20
Router>encapsulation dot1q 20
Router>ip address 192.168.20.1 255.255.255.0
Router>ip dhcp pool societe2
Router>network 192.168.20.0 255.255.255.0
Router>default-router 192.168.20.1
Router>ip dhcp excluded-address 192.168.20.1 192.168.20.100
Router>ip dhcp excluded-address 192.168.20.200 192.168.20.254
Router>int f0.30
Router>encapsulation dot1q 30
Router>ip address 192.168.30.1 255.255.255.0
Router>ip dhcp pool societe3
Router>network 192.168.30.0 255.255.255.0
Router>default-router 192.168.30.1
Router>ip dhcp excluded-address 192.168.30.1 192.168.30.100
Router>ip dhcp excluded-address 192.168.30.200 192.168.30.254
Router>Ctrl+Z
Router>wr mem



Vous noterez les sous interfaces. En effet, pour une interface physique sur le routeur, ici F0, elle a été divisée en 3 sous interfaces: F0.10, F0.20 et F0.30. Le nombre de sous interfaces est limitée, mais il y a de la marge! Une sous interface par VLAN, donc 3 dans notre cas.
Ce site est la propriété exclusive de Christelle Copyright © 2002-2009